请选择 进入手机版 | 继续访问电脑版

CE学前班

 找回密码
 立即注册
搜索
热搜: CE工具 OD工具
查看: 147|回复: 4

[已经解决] 求小伙伴们帮助一下!!!十万火急

 关闭 [复制链接]

5

主题

58

帖子

357

积分

用户组:反汇编菜鸟

UID
3257
好评
0
金钱
299
贡献
0
原创
0
在线时间
13 小时
注册时间
2022-4-16
发表于 2022-6-7 18:11:38 | 显示全部楼层 |阅读模式
50金钱
易语言取矩阵数值取不到 我尝试调试输出 矩阵地址 都是对的

调试输出(ViewWorld)这个的时候 就是取不到任何数值
还是算法错了 导致取不到

求解答

调试输出

调试输出

算法

算法

最佳答案

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。

友情提醒:本版被采纳的主题可在您的回复帖子中申请贡献值,获得 1点

每月奖励:月底按排行榜进行奖励,第一名奖励 RMB100

快捷通道:我的回答查看本月排行榜

回复

使用道具 举报

48

主题

244

帖子

5438

积分

用户组:管理员

UID
1
好评
1
金钱
5154
贡献
3
原创
1
在线时间
406 小时
注册时间
2022-2-25
发表于 2022-6-7 18:32:55 | 显示全部楼层
.版本 2

.数据类型 D3D坐标, 公开
    .成员 X, 小数型
    .成员 Z, 小数型
    .成员 Y, 小数型

.版本 2

.数据类型 D2D坐标, 公开
    .成员 X, 小数型
    .成员 Y, 小数型
回复

使用道具 举报

48

主题

244

帖子

5438

积分

用户组:管理员

UID
1
好评
1
金钱
5154
贡献
3
原创
1
在线时间
406 小时
注册时间
2022-2-25
发表于 2022-6-7 18:18:16 | 显示全部楼层
3D转2D,我记得很多FPS的辅助代码都有,可以去参考一下
回复

使用道具 举报

5

主题

58

帖子

357

积分

用户组:反汇编菜鸟

UID
3257
好评
0
金钱
299
贡献
0
原创
0
在线时间
13 小时
注册时间
2022-4-16
 楼主| 发表于 2022-6-7 18:12:35 | 显示全部楼层
调试输出 矩阵地址是对的    但是就是取不到值
有没有懂的小伙伴 帮忙解答一下
回复

使用道具 举报

48

主题

244

帖子

5438

积分

用户组:管理员

UID
1
好评
1
金钱
5154
贡献
3
原创
1
在线时间
406 小时
注册时间
2022-2-25
发表于 2022-6-7 18:11:39 | 显示全部楼层
  1. .版本 2

  2. .子程序 _3D转2D, 逻辑型
  3. .参数 对象坐标, D3D坐标
  4. .参数 返回2D, D2D坐标, 参考 可空
  5. .参数 返回距离, 整数型, 参考 可空
  6. .局部变量 ViewW, 小数型
  7. .局部变量 BoxX, 整数型
  8. .局部变量 BOXY, 整数型

  9. ViewW = ViewWorld [1] [4] × 对象坐标.X + ViewWorld [2] [4] × 对象坐标.Y + ViewWorld [3] [4] × 对象坐标.Z + ViewWorld [4] [4]
  10. 返回距离 = 取整 (ViewW ÷ 100)
  11. .如果真 (ViewW ≤ 0.01)
  12.     返回 (假)
  13. .如果真结束
  14. ViewW = 1 ÷ ViewW
  15. BoxX = 全_SightX + (ViewWorld [1] [1] × 对象坐标.X + ViewWorld [2] [1] × 对象坐标.Y + ViewWorld [3] [1] × 对象坐标.Z + ViewWorld [4] [1]) × ViewW × 全_SightX
  16. BOXY = 全_SightY - (ViewWorld [1] [2] × 对象坐标.X + ViewWorld [2] [2] × 对象坐标.Y + ViewWorld [3] [2] × 对象坐标.Z + ViewWorld [4] [2]) × ViewW × 全_SightY
  17. 返回2D.X = 到整数 (BoxX)
  18. 返回2D.Y = 到整数 (BOXY)
  19. 返回 (真)
复制代码

评分

参与人数 1金钱 +3 收起 理由
奶酪 + 3 大神,请收下我的膝盖

查看全部评分

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125 邮箱:lsptzcom@126.com
Powered by Discuz! X3.4 CE学前班模块| 手机版| 联系我们| CE学前班

快速回复 返回顶部 返回列表